Weryfikacja plików - status usunięty

Błąd   Założony przez Bouli.

Wersja silnika: 
[1.8.20]


Opis problemu:
Po aktualizacji skryptu na 1.8.20 w panelu administratora weryfikacja plików wywala mi status "usunięty" dla bardzo wielu plików, wszystkie w folderach:
  • /admin
  • /archive
  • /cache
  • /images
  • /inc
  • /install
  • /jscripts
  • /upload
pliki oczywiście na serwie są a nadpisanie z nowej paczki nic nie zmienia, ktoś coś rozumie????
Upewnij sie, ze pliki maja prawidlowe uprawnienia i wlasciciela (chmod i chown).
Kodowanie, edycja i tworzenie styli, for, stron, poszczególnych elementów - polecane szczególnie dla osób, które nie potrafią sobie poradzić z problemami.

Sprzedam Styl (RWD): https://webboard.pl/thread-74571.html
na przykładzie /admin (755)
wszystkie foldery wewnątrz 755, pliki 644
jak sprawdzić właściciela?? ftp mi pokazuje właściciel "nobody"
Zalogowałem się po ssh i właściciel i grupa to bouli z tym że tak jest i było od początku na tym serwie, więc raczej nie tu jest problem, jak jest u was na serwerach??
Inne foldery i pliki również tak mają? Mam na myśli te działające.
Spróbuj przenieść mybb na inny serwer i sprawdzić czy problem będzie dalej występować. Będziemy wiedzieć, czy wina jest po stronie serwera czy mybb.

Jaki masz serwer? Jeśli apache to upewnij się, że htaccess ma nazwę .htaccess (nie htaccess.txt), a jeśli nginx to upewnij się, że masz wklejoną konfiguracje mybb do plików konfiguracyjnych serwera (najprawdopodobniej nginx.conf). Ktoś pisał, że to też może powodować błędy z weryfikacją.
Kodowanie, edycja i tworzenie styli, for, stron, poszczególnych elementów - polecane szczególnie dla osób, które nie potrafią sobie poradzić z problemami.

Sprzedam Styl (RWD): https://webboard.pl/thread-74571.html
(16.03.2019, 13:38)Divir napisał(a): Inne foldery i pliki również tak mają? Mam na myśli te działające.

Wszystkie katalogi i pliki w folderze forum mają takiego samego właściciela i grupę, pomimo że, weryfikacja plików pokazuje że tych plików i folderów nie ma to wszystko działa, forum normalnie ładuje się, to tak jakby sam komunikat o braku był błędny "na moje bolka oko" to weryfikacja plików nie jest w stanie sprawdzić tego w katalogu z tym że sama w sobie raczej jakoś działa, bo zmodyfikowane pliki .php wykazuje na liście a po w graniu z paczki oryginalnych już nie ;)

(16.03.2019, 13:38)Divir napisał(a): Spróbuj przenieść mybb na inny serwer i sprawdzić czy problem będzie dalej występować. Będziemy wiedzieć, czy wina jest po stronie serwera czy mybb.

Nie bardzo mam gdzie to przenieść, spróbuje zainstalować w innym katalogu czyściutkie mybb i sprawdzę czy to się odnosi do serwera czy może tylko do mojej istniejącej instalacji.

(16.03.2019, 13:38)Divir napisał(a): Jaki masz serwer? Jeśli apache to upewnij się, że htaccess ma nazwę .htaccess (nie htaccess.txt), a jeśli nginx to upewnij się, że masz wklejoną konfiguracje mybb do plików konfiguracyjnych serwera (najprawdopodobniej nginx.conf). Ktoś pisał, że to też może powodować błędy z weryfikacją.

źle się chyba wyraziłem, fizycznie nie posiadam serwera, opłacam na home.pl ;)
Linux, .htaccess jest w głównym katalogu forum w oryginalnej wersji, ja tylko dopisałem:

RewriteEngine On
RewriteCond %{HTTPS} !=on [NC]
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Options -MultiViews +FollowSymlinks -Indexes
(16.03.2019, 16:53)Bouli napisał(a): Nie bardzo mam gdzie to przenieść, spróbuje zainstalować w innym katalogu czyściutkie mybb i sprawdzę czy to się odnosi do serwera czy może tylko do mojej istniejącej instalacji.
Nawet localhost, żeby sprawdzić inny serwer. Ewentualnie możesz uzyc darmowego hostingu typu ct8 lub kupic jakis za 3zl nawet.

(16.03.2019, 16:53)Bouli napisał(a): źle się chyba wyraziłem, fizycznie nie posiadam serwera, opłacam na home.pl
Linux, .htaccess jest w głównym katalogu forum w oryginalnej wersji, ja tylko dopisałem:
Miałem na myśli jaki posiadasz serwer web zainstalowany na tym linuxie. ;) Ale w takim razie domyslam sie, ze apache.
Kodowanie, edycja i tworzenie styli, for, stron, poszczególnych elementów - polecane szczególnie dla osób, które nie potrafią sobie poradzić z problemami.

Sprzedam Styl (RWD): https://webboard.pl/thread-74571.html
ze strony hostingu wynika że Apache 2.4
zainstalowałem czyste myBB 1.8.20 w innym katalogu i wszystko działa, weryfikacja plików wywala tylko zmianę w pliku inc/functions_indicators.php i to po zainstalowaniu TOP STATS bo wcześniej było czyściutko więc chyba coś nie pykło po aktualizacji.
Zawsze możesz do czystego mybb wrzucić pluginy i podpiąć obecną bazę danych. Może któryś z pluginów coś psuje?
Kodowanie, edycja i tworzenie styli, for, stron, poszczególnych elementów - polecane szczególnie dla osób, które nie potrafią sobie poradzić z problemami.

Sprzedam Styl (RWD): https://webboard.pl/thread-74571.html
zrobiłem kopię bazy i importowałem do tej czystej wersji z pluginami i weryfikacja działa poprawnie, nie wiem gdzie może być problem, generalnie coś się dzieje z tym forum bo jak się wyloguje i loguje ponownie to dostaje sporadycznie komunikat "Niepoprawny kod autoryzacji....." po czym ponowne logowanie już przebiega normalnie a w szablonie mam już z poprzedniej aktualizacji uzupełnione szablony o:

<input name="my_post_key" type="hidden" value="{$mybb->post_code}" />



Użytkownicy przeglądający ten wątek:

1 gości